Home_greyopenFATE - openSUSE feature tracking > #323325
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Make "--no-allow-vendor-change" the default option for "zypper dup"

Feature state

openSUSE Factory
New

Description

By reading the forums and the mailing list, I learned that the preferred way to update Tumbleweed is to use

sudo zypper dup --no-allow-vendor-change

Since updating a rolling distro is a task that is to be done regularly, I think that setting the "--no-allow-vendor-change" option as the default one could be desirable

User benefit:

To have an easier and faster update process.

Relations

  • Related feature #323478: 323478

Discussion


icons/user_comment.png M. A. wrote: (8 weeks ago)

'solver.dupAllowVendorChange = false' is the zypp.conf default on TW since libzypp-16.13.0 (see bsc#1031756).

Last change: 8 weeks ago
Voting
Score: 4
  • Negative: 0
  • Neutral: 0
  • Positive: 4
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint