Home_greyopenFATE - openSUSE feature tracking > #312880
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

change QCAD to LibreCAD

Feature state

Package Wishlist
Done
openSUSE Distribution
Done

Description

Remove the very old unmantained QCAD (it requires QT3!!!) and add LibreCAD a mantained port to QT4
http://librecad.org

Discussion


icons/user_comment.png J. E. wrote: (2 years ago)

Now in /graphics.

icons/user_comment.png J. B. wrote: (2 years ago)

haha, i love how quickly can move on this stuff. :)

icons/user_comment.png K. K. wrote: (2 years ago)

IMHO, Education repository is a better place, because it already has such CAD programs as QCad, CADEMIA, HeeksCAD...

icons/user_comment.png J. E. wrote: (2 years ago)

Education is about the worst place to put it, because there is so much software that, in one way or another, can be useful in and for one's education. In other words, "Education" is too coarse a label. And there is far too much software that clearly /is not/ education-related in the Education project.

icons/user_comment.png J. S. wrote: (2 years ago)

I installed the package from graphics and is packaged only the binary but the font and pattern files are needed and not present.
One desktop file would be nice.

From:
https://build.opensuse.org/package/show?package=LibreCAD&project=home:Rallaz
you can get a librecad.desktop (and more info about fonts & patterns)

icons/user_comment.png J. E. wrote: (2 years ago)

Part of the problem is also that there is no `make install` provided in librecad. gnaaaa...

icons/user_comment.png J. S. wrote: (2 years ago)

At the end of make process is executed "scripts/postprocess-unix.sh", this shell script is responsible to realize the installation but in the build tree.
patching the line 4
RESOURCEDIR="`pwd`/unix/resources"

the install is realized in the build process

icons/user_comment.png J. M. wrote: (2 years ago)

LibreCAD 1.0 is now released.
http://www.h-online.com/open/news/item/LibreCAD-1-0-released-1404215.html
and the rpm packages on the website seem to work great!
http://librecad.org/cms/home/installation/rpm-packages.html

icons/user_comment.png J. E. wrote: (2 years ago)

Shipping LibreCAD is not possible ATM due to conflicting licenses between LibreCAD (GPL-2.0) and one of its dependencies, fparser (LGPL-3.0).

icons/user_comment.png J. E. wrote: (2 years ago)

Cleared up with new version, proceeding.

Last change: 2 years ago
Voting
Score: 20
  • Negative: 0
  • Neutral: 0
  • Positive: 20
Tags
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint