Home_greyopenFATE - openSUSE feature tracking > #312728
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Package Software Center with PackageKit backend

Feature state

Package Wishlist
Marketplace

Description

As a result of 2011 GSoC - PackageKit backend and AppStream integration for Software Center, software-center and dependencies need to be packaged for testing in openSUSE.

The list of dependencies is:

  • python-gobject - 2.90.1 or newer
  • PackageKit - 0.6.16 or newer
  • software-center itself - 4.1.18 or newer
  • python-piston-mini - 0.5 or newer (https://code.launchpad.net/piston-mini-client )
  • python-xapian - 1.2.5 (provided by xapian-bindings, xapian-core)
  • python-lazr.restfulclient - ?!

Other dependencies: - po4a (needed by software-center setup.py)

User benefit:

Once this is done, wide testing can be done for the
AppStream enabled client.

Relations

Discussion


icons/user_comment.png J. B. wrote: (6 years ago)

as long as we get a bretzn front-end i am all in favour.

Last change: 5 years ago
Voting
Tags
Loading tags...
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint