Home_greyopenFATE - openSUSE feature tracking > #312617
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

drop libxcrypt

Feature state

openSUSE Distribution
Done

Description

libxcrypt is nowadays mostly superfluous as glibc supports sha256 and sha512 itself. blowfish and the gensalt functions can be patched in via crypt_blowfish addon.

Needed adjustments:
- glibc
- pam
- pam-modules (pam_unix2)
- pwdutils
- yast2-core

Disadvantage:
we currently lose support for bigcrypt.

Discussion


icons/user_comment.png A. J. wrote: (2 years ago)

The work for glibc has been done - hasn't it?

icons/user_comment.png A. J. wrote: (2 years ago)

Ludwig, Thorsten, what kind of work is needed for pam, pam-modules and pwdutils?

icons/user_comment.png T. K. wrote: (2 years ago)

Nothing, done since ages.

icons/user_comment.png A. J. wrote: (2 years ago)

Then let's fix YaST. Jiri, could you get somebody to fix yast2-core (and what else requires libxcrypt), please?

icons/user_comment.png J. S. wrote: (2 years ago)

Lukas, Duncan, can either Martin or Arvin (or someone else) look at it? This requirement sounds to me very valid.

icons/user_comment.png D. M. wrote: (2 years ago)

I will ask Arvin. Lets keep the cloud team alone for now :-)

icons/user_comment.png A. S. wrote: (2 years ago)

I have removed xcrypt from yast2-core. Removes bigcrypt support from YCP but that seems to be unused already.

icons/user_comment.png A. J. wrote: (2 years ago)

Everything done now - thanks!

Last change: 2 years ago
Voting
Score: 2
  • Negative: 0
  • Neutral: 0
  • Positive: 2
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint