Home_greyopenFATE - openSUSE feature tracking > #310080
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

KDE 4.6 for opensuse 11.4

Feature state

openSUSE-11.4
Done

Description

I realise we are using a time based release, and no longer chase feature releases, but 11.3 will ship with KDE 4.4 when 4.5 will ship three weeks later.

I realise you don't just drop in an entirely new DE version a week before opensuse hits RC, but it would be a crying shame for two releases in a row, eight months apart, both to use an 'old' major release of KDE.

For this reason I would be very keen to look at the KDE 4.6 release schedule (should be end of january), and see if we cannot plan to include it in opensuse 11.4 (which in theory is due end of february at the earliest).

Were it possible to get 4.6.1 for point release stability that would be even better.

Kind regards

Discussion


icons/user_comment.png S. S. wrote: (4 years ago)

There will without a doubt be repos for 4.5 and 4.6 when its ready for 11.3.  Just not in the update channel

icons/user_comment.png j. b. wrote: (4 years ago)

this is a request for 11.4, not 11.3. :)

icons/user_comment.png J. B. wrote: (4 years ago)

Which is all well and good, but that only works for savvy users...seems like it would be better as a whole to ship with it, but if suse is stuck in time cycles I guess that the repositories is all we can hope for.

Another thought then...where it gives the instructions for upgrading in the wiki and the one-click install...perhaps add all three Factory KDE repositories...I believe they are the community, factory desktop, and playground (or at least the first two) and explain that using zypper dup (or related feature through gui) would be a good idea.

I have found that upgrading purely by the one-click produces odd bugs and they change over time as other packages are updated, but if I use dup to switch over ALL kde packages not just the ones listed in ymp thing are much more stable.

So if suse is going to stick to ignoring the KDE release schedule (which is fine) then perhaps we can make the manual upgrade better...maybe even suggest it through the upgrade channel or something.

icons/user_comment.png j. b. wrote: (4 years ago)

suse is stuck in time cycles, but it has proven to be flexible on a scale of weeks, and given that there there is already a month of 'play' I would like it to be considered a core target for 11.4.

icons/user_comment.png D. W. wrote: (3 years ago)

It has been already confirmed that 11.3 will ship with 4.6. Have a look here:

http://mschlander.wordpress.com/2010/07/09/attention-opensuse-kde-factory-users/

icons/user_comment.png j. b. wrote: (3 years ago)

awesome news, cheers.

icons/user_comment.png s. s. wrote: (3 years ago)

I dont think so.

11.3 will ship with 4.4.

As it will ship, 4.4 comes to stable, 4.5 -> Factory.

Its usual shift.

icons/user_comment.png j. b. wrote: (3 years ago)

i believe he meant 11.4, given that this topic is about 11.4, and his link refers to 11.3+1.

icons/user_comment.png j. b. wrote: (3 years ago)

any news on this? confirmed, rejected, deferred, etc............?

it has been there for two months now give or take, and in the top 20 11.4 requests for nearly as long, surely it merits either an "evaluation" or a "rejected" by this point?

openfate seems much less responsive these days.

icons/user_comment.png j. b. wrote: (3 years ago)

"hellooooooooooooooo.......................................?"

icons/user_comment.png O. R. wrote: (3 years ago)

Too bleeding edge. I really like how openSUSE has been using "outdated" KDE with 4.x.y, where y > 3, meaning stability has been great.

icons/user_comment.png j. b. wrote: (3 years ago)

are you suggesting it would be inappropriate for opensuse 11.4 to use KDE 4.6?

icons/user_comment.png T. Z. wrote: (3 years ago)

You're wrong, openSUSE 11.2 shiped with KDE 4.3.1 (instead of KDE 4.3.2 which was released a couple of weeks before the openSUSE release).

icons/user_comment.png С. М. wrote: (3 years ago)

I think it does not matter which version of KDE will be installed on openSUSE 11.4. Most important is stability reason. I vote against this feature.

icons/user_comment.png D. B. wrote: (3 years ago)

talking about stability:

Every new version adds stability kde4 desparately needs for several versions now, and opensuse as one of the (if not THE) major kde distribution has damaged it's reputation because of that.

Another one regarding stability:

Did anybody not voting for this issue use Kontact recently? Mail/Address/Calendar is a core functionality that needs to be working and the only way i see to get this is by moving on to 4.6, hoping that the kdepim team will stick to their dev plans and get that properly up and running by the 4.6 release.

icons/user_comment.png j. b. wrote: (3 years ago)

agreed.

icons/user_comment.png A. B. wrote: (3 years ago)

Running natively 11.4, nepomuk always throw an error, but I hope the new version come with 4.6!

icons/user_comment.png j. b. wrote: (3 years ago)

http://www.mail-archive.com/release-team@kde.org/msg03829.html

  • Thu, Jan 20 2011, openSUSE 11.4 Milestone 6 release
  • Thu, Feb 10 2011, openSUSE 11.4 RC 1 release
icons/user_comment.png S. L. wrote: (3 years ago)

I'm using KDESC 4.6 beta 1 and KDESC 4.6 beta 2 on my OpenSUSE 11.3 and older KDESC 4.6 than beta 1 on VirtualBox with OpenSUSE 11.4 . Every think works fine and some oddest bug present in KDESC 4.5 are removed.

icons/user_comment.png S. L. wrote: (3 years ago)

It's not real matter for me - I will update my system to 11.4 version, but ... What if some think happens wrong? I will made new installation, so I must prepare to install KDESC 4.6 and download 1GiB of data.

Last change: 3 years ago
Voting
Score: 67
  • Negative: 5
  • Neutral: 2
  • Positive: 72
Tags
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint