Home_greyopenFATE - openSUSE feature tracking > #309504
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Update dhcpcd to 5.2.2

Feature state

openSUSE Distribution
Rejected Information

Description

Upgrade from dhcpcd v3.2.3.x, which is in openSUSE 11.2 and 11.3-Factory, to v5.2.2.
It seems that we are using a very old dhcpcd that has many issues, some that won't be fixed because they are addressed in more recent releases. So why not upgrade to a current version?
v5.2.2 was released on March 31, 2010.
v3.2.3 was released over two years ago on Feb 25, 2008

If this can't make it into 11.3 then put on the list for 11.4
Cheers,
Ron

Discussion


icons/user_comment.png M. K. wrote: (7 years ago)

Outdated 3.x is unsupported upstream and has well known bugs which will not / cannot get resolved with 3.x.
E.g. I verified that
https://bugzilla.novell.com/show_bug.cgi?id=657402 is fixed in 5.x
From the upstream author of dhcpcd Roy Marples:

> I only recently got dhcpcd updated in Debian to dhcpcd-5 from
> dhcpcd-3.
> That involves a new package the worked alongside dhcpcd-3 because
> dhcpcd-5 now works as a single process on all interfaces. It can still
> work per interface but not 100% the same way with dhcpcd-3. SuSE may
> wish to go the same way.

The same applies to SLES11/SLED11 there also an update is needed because the issues cannot be reasonably be fixed in 3.x.

Last change: 12 months ago
Voting
Score: 3
  • Negative: 1
  • Neutral: 0
  • Positive: 4
Tags
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint