Home_greyopenFATE - openSUSE feature tracking > #308522
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Blacklist Updates

Feature state

openSUSE-11.3
Unconfirmed

Description

Users should have the ability to blacklist an update and never be reminded of it again.

This can be done to an extent using the terminal but that's not perfect either.

Because of this I have uninstalled the Updater applet and now use strictly zypper to run updates.

The Updater applet will be promptly uninstalled by me on all versions of openSUSE until this feature can be added.

Keep up the good work openSUSE team!

Discussion


icons/user_comment.png T. S. wrote: (8 years ago)

Setting a package to "protected" in yast did not skip the updater applet from updating it...
It tries to update it, but fails for example with:
PackageKit Error dep-resolution-failed: patch:ntp-1728.noarch conflicts with ntp.i586
Is this a bug?

icons/user_comment.png T. G. wrote: (8 years ago)

I guess you are talking about kupdateapplet. kupdateapplet uses libzypp via packagekit or zypper. libzypp should honor locked packages. If it doesn't it's a bug. Could you please report a bug against libzypp and attach zypp-logs. Thank you very much.

Last change: 8 years ago
Voting
Score: 2
  • Negative: 0
  • Neutral: 1
  • Positive: 2
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint