Home_greyopenFATE - openSUSE feature tracking > #306326
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

mount encrypted /home before user config

Feature state

openSUSE-11.2
Done

Description

Taken from bugzilla, requested by development.

When installing with an encrypted /home partition I am informed
during user creation that the /home partition is not mounted (see
screenshot in bugzilla).

What is missing here is the possibility to enter the password for
the partition, mount the partiton and continue with the user
configuration.

Relations

Discussion


icons/user_comment.png S. K. wrote: (8 years ago)

according to the bugzilla, it's a cryptsetup feature.

icons/user_comment.png L. N. wrote: (8 years ago)

The default timeout for partitions is two minutes. If some partition should not have a timeout the option 'timeout=0' needs to be specified in crypttab. I would not recommend to do that by default for any partition though. I could set the timeout to 0 if /var/lib/YaST2/runme_at_boot is present to have an exception for 2nd stage install.

icons/user_comment.png M. E. wrote: (8 years ago)

@Stefan - where should the password/passphrase be entered: cmdline or YaST (2nd stage)?

icons/user_comment.png S. B. wrote: (8 years ago)

Comment 2 sounds like a valid aproach.

icons/user_comment.png S. B. wrote: (7 years ago)

Marcus, any update?

icons/user_comment.png L. N. wrote: (7 years ago)

implemented in Factory as described in comment #2

Last change: 7 years ago
Voting
Score: 3
  • Negative: 0
  • Neutral: 0
  • Positive: 3
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint