Home_greyopenFATE - openSUSE feature tracking > #306304
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Support "Obsolete this by another package"

Feature state

openSUSE-11.2
Rejected Information

Description

If third party wants to terminate temporary branch of a package, which should be obsoleted by the mainline, adding
Obsoletes: foo-old-branch
into the mainline package is not an option (it's possible only for official packages).

Support for an Obsolete tag counterpart initiated by the existing package would fix this situation.

Example:

Name: gimp-unstable 
Version: 2.5.23
Provides: gimp = %{version}
ObsoleteBy: gimp >= 2.6

It would allow to provide mainline gimp packages without
Obsoletes: gimp-unstable < 2.6
and even allow third parties to create temporary branches of packages.

User benefit:

Providing a significantly modified packages, that are known to be obsolete after upgrade to the next mainline version.

Discussion


icons/user_comment.png A. J. wrote: (8 years ago)

Klaus, could you comment on this, please?

icons/user_comment.png K. K. wrote: (8 years ago)

This seems to complete our "reverse dependencies". Michael, your opinion ?

icons/user_comment.png F. L. wrote: (8 years ago)

This smells like trouble - RPM compatibility ?

I am not too keen on third parties branching packages, looks like yet-another-mess... what are the use cases we are looking at solving here?

icons/user_comment.png M. S. wrote: (8 years ago)

Please discuss this first with the upstream rpm-maint list. I strongly against adding this just to our rpm version. (And it should be ObsoletedBy ;-) )

(We could also add a hack to the sat solver so that

Provides: obsoletedby(gimp) >= 2.6

or

Obsoletes: obsoletedby(gimp) >= 2.6

works, but this is way too ugly for my taste)

Last change: 8 years ago
Voting
Score: 5
  • Negative: 0
  • Neutral: 0
  • Positive: 5
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint