Home_greyopenFATE - openSUSE feature tracking > #305550
Dashboard | Search | Sign up | Login

Please login or register to be able to edit or vote this feature.

Port of YaST Qt Control Center to Qt4

Feature state



The YaST Qt Control Center is one of the few remaining parts of the desktop still requiring Qt3. It should be ported to Qt4.


  • Boot up openSUSE 11.2 with KDE4.
  • Start Yast2. Check if it is QT4.
  • Check if it is linked to libqt4: ldd /usr/lib/YaST2/bin/y2controlcenter | grep libqt


icons/user_comment.png A. M. wrote: (7 years ago)

I vote for it. Is there any way to vote for a feature here?

It's quite annoying the disintegration that yast-qt brings to KDE4 desktop.

icons/user_comment.png M. L. wrote: (7 years ago)

Voting is not possible yet with openFate. But it is planned to implement as it is a good tool to estimate community demand for a feature. I just found an older Fate request addressing this and make it public - #302963

icons/user_comment.png S. K. wrote: (7 years ago)

from what I understand, this is already in implementation.

icons/user_comment.png W. G. wrote: (6 years ago)

If you install a little bit of Factory, you will get a Qt4 version of Yast.

icons/user_comment.png R. M. wrote: (6 years ago)

This feature is now done and YaST Qt4 is currently building in Factory. Thx to the YaST's folk :)


icons/user_comment.png j. b. wrote: (6 years ago)

This is one I would like to see.

11.2 should not need KDE3 for any core components or default apps.

Last change: 6 years ago
Score: 84
  • Negative: 0
  • Neutral: 0
  • Positive: 84
Feature Export
Application-xmlXML   Text-x-logPlaintext   PrinterPrint